Support

Open search

A50 camera black screen

Observer

I bought a Galaxy A50 5 days ago. The first couple of days everything was OK - the camera was working, I shot a few pictures with it and a few slow-motion videos.

Yesterday, when I tried to open the camera app it was not working. Some of the in-app buttons are there, but with no working functionality

  • the shutter button is there, but it does nothing
  • the galery button is there, but there is no picture inside of it and I can't open the galery by using it
  • the button for switching between the front and back camera is there, but it does not work, too
  • the camera mode buttons are there but I cannot cycle through them.

At first, I thought the problem is in the camera app and I tried to open Facebook Messenger and to test if the camera is working there, but it is showing only a black screen - the same as in the camera app.

 

Then I downloaded a 3rd party camera app in order to test if it will connect to the phone's camera, but that app is also not working. It also shows a blank screen.

 

Summary: Galaxy A50 camera does not work with the phone's camera app, with Facebook Messenger and with a 3rd party camera app. It shows black screen and buttons are missing or not working.

6 REPLIES 6
CarlH Moderator
Moderator

Hi @thedemonhunter. If you dial *#0*# and select Mega Cam, does anything appear then? 

Observer

All black screen opens with the 3 android buttons at the bottom, but none of them works. I can't back, I can't go to the home screen, I can't open the recent apps.

 

Now a few seconds later a message popped up: "Factory camera doesn't respond" with the options to close, wait or send feedback.

 

When I click on "Close" it closes at last.

 

One more interesting thing is that the same happens if I select "front camera" instead of "Mega Cam". Just for your information. Now I get stuck in the front camera, too, and will wait for it to pop that message up. Here it is, I click close, otherwise I can't get out of the front camera.

Observer
Otherwise, I tested the sensor - it shows some accelerometer data, the touch - it also works, red, green and blue light up the screen with the corresponding color, vibration works, speaker works, but front camera and mega cam crash.
CarlH Moderator
Moderator

Thanks for the info, @thedemonhunter. Can you check the camera in Safe Mode? To activate this, restart your phone but whilst it's powering up, keep the 'Volume Down' button held until you reach the home screen (Safe Mode will be displayed in the bottom left corner).  

Observer

Same thing with the black screen even in Save Mode. But with the phone now stuck in the Mega Cam. Now it crashed and we are back to square one.

Highlighted
CarlH Moderator
Moderator

If there are no software updates pending, I would return it to the retailer for a replacement, @thedemonhunter.

Top Liked Authors