Support

Open search

portable blu ray writer Model SE-506, firmware update and windows 10 driver needed

Apprentice

Hi,

 

I tried the SE-506, build May 2013, with a Dell XPS 9350 running Win10/Ubuntu. I got it to read one CD with Windows; no luck at all with Ubuntu. I tried it with a 2008-eara Mackbook Pro 5,1; it was able to read one CD, but not some other tests. I tried a few different cables; no luck. I tried the registry edit suggested in this thread; no luck.

 

ETA: Just tried it with my work laptop, a Thinkpad T480S (Win10). The drive read CDs, DVDs, and Blu-Rays, no issues. Unfortuantely I am not able to install software on this laptop (and if Windows had tried to install something, I'd have been notified), but I think this verifies that this an issue between certain computers and the BR drive, not necessarily Windows 10 and the drive.

 

None of this solves what I was originally trying to do, which was just rip some CDs to Ogg/FLAC, but hey, I killed two hours debugging old hardware in order to not solve anything.

 

E2TA:

And lo, a solution appears: Connecting a DA-200 dock to the XPS 9350's USB-C port, then connecting the SE-506 to the DA-200, let me read CDs, DVDs, and Blu-Rays! CD ripping and DVD playback work fine. (I don't have a way to test Blu-Ray playback.)

 

I also tried running the SE-506 off of an old USB 2.0 dock that I have - an IOGear GUH420! - and was NOT able to load any media via that pathway.

 

I wonder if something like this (https://www.amazon.com/dp/B077GRXXYV/) would do the trick, without needing a dock, but obviously taking up a USB-C slot. (Have not ordered or tested.)

 

E3TA: Maybe I need to take all of that back. After successfully reading one CD, the XPS 9350 stopped reading any of them. Windows tries, but can't quite pull it off.

Apprentice

Update: this cable (https://www.amazon.com/dp/B077GRXXYV/) let me read a couple of CDs, but ripping them failed. As such, not a solution.

Apprentice
bienvenido amigo al club de los defraudados.!
New Member
I was about to throw the thing away, your advice just saved me 100 bucks, thanks!
Apprentice

You should probably just throw it away; I haven't gotten it to work, except with one ThinkPad laptop I no longer have access to.

First Poster

It may be a DRM problem. Check out this thread on the Microsoft forums. BTW, loops back to this thread.

https://answers.microsoft.com/en-us/windows/forum/all/external-blu-ray-writer-samsung-se-506cb-doesn...

 

Even with CyberLink PowerDVD 18 installed (as suggested by MS) on my Win10 Pro system, I still get stuttering and other problems. Will try out the dual-power option next.

Apprentice

I was able to solve this problem with my Samsung Model SE-506.   This burner worked fine on other PC's, but we had switched it over to a small form factor Atom x5-z8350 based system to replace a server for use as a single FTP push backup function.  The system logged in with an MS cloud-based account (somename@outlook.com), the default Microsoft pushes upon default installations (this is windows 10 pro os build 17763.379). Long story short, like many others having problems with this burner, we were getting the message indicating that it could not read the Blu-ray disks. After having tried many different solutions including the double USB wire, we came to the conclusion that it was a rights issue.   Upon inspection, the ‘local’ administrator account was disabled (we were logging in with an MS account). We enabled the local admin account and logged in with this which apparently provides the necessary rights to this device allowing it to function as intended. Hope this helps.

Apprentice

have you tested it? in the past, i tried in a windows 10 machine using local admin account without success....you talking about any local admin account or local administrator account? thanks for your reply

Apprentice

Yes, the local Administrator account .  Yes, it is working now just as of yesterday (04-03-2019).  I can recreate the same issue by moving back to the Ms cloud account and disabling the local Administrator account as was the case by default after installation of Win 10 pro. 

Apprentice
thank you for your reply, i will test it today and inform here later.
Top Liked Authors