Support

Open search

portable blu ray writer Model SE-506, firmware update and windows 10 driver needed

Explorer

hi again

 

it's doesn't work for me, i activate local admin account and logged in, connect bd drive and test with a bd disc recorded with the same burner, but no results, windows detects unit as a bd recorder, but doesn't recognize disc....any other thing you do in your machine? i think everybody aprecciated your help if you ilustrate more deeply your experience... thanks

Highlighted
Apprentice

OK, l'll post a video tommorow to demostrate... I'm sorry it didn't work for you... 

 

 

 

 

 

First Poster

I'm burned out over this whole thing. I've been building home-brew systems since 1985. I know and understand system integration. High-end systems engineering paid my salary for my career (45 years) until I retired a couple of years ago. This farago strikes me not as an engineering failure, but a marketing failure. I designed and built a perfectly servicable "soccer-mom van" of a system (gigabyte b360n wifi motherboard, i3-8100 cpu, 32Gb DDR4 ram, Intel SSD, and the optical media player at the center of this all). When I searched out the problems I was having on the MS site, I discovered that, with the propogation of the last year Win update, MS support of the many BRD licensing support options was being abandoned. So, suddenly, we were all left without BRD support (and my DVD support is shaky, at best).  This wasn't the fault of some cadre of MS engineers but the result of some clique of marketing droids (no, I'm not biased after 45 years in the business).  Enough, already! I've ordered a purpose built "smart" BRD player for my man-eyrie and will convert my Win10 entertainment player brick into an Xubuntu Mystery Machine! So long and thanks for all the fish!

 

Apprentice

Hi everyone

First - sorry for my poor language.

 

A few information:
- I bought my SE-506CB/RSBD in 2014. I use this optical drive on Windows 7 Sp1 x64 and Windows 10 x64 Pro [from build 1604].
- Now I have installed on my PC Windows 10 Pro x64 [bulid 1809].
- Usually I work on local account without admin permission.
- I upgraded firmware to TS02.

 

My tips for Owners:

 

1. Check Yours cable - my original of Samsung was broken. Now I use InLine USB 2.0
2. Always connect optical drive to USB 2.0/3.0/3.1 on your motherboard - not on USB's on front panel yours PC case
3. To burn BR disc use free soft: BurnAware Free [current version: 12.3]
4. To play BR disc I use "AnyMP4 Blu-ray Player" [version: 6.3.22]. The original, a free copy I have download from giveawayoftheday

Explorer
thanks! i will try your software recomendation... but can you burn successfull bd discs?
Apprentice

Hi

 

I burn only data [my files: docs, photos, video etc.] on BR disc. I burned around 80x 25GB discs - 99% was successful (maybe one or two was wasted?)


I try to burn a few 50GB discs - around 75% was successful.

 

I use this 25GB discs:
http://esperanza.pl/bd-r-esperanza-25gb-x4---cake-box-10pcs-,151,416.html
https://www.verbatim-europe.co.uk/en/prod/bd-r-sl-datalife-25gb-6x-25-pack-spindle-43837/

New Member
Woohoo!

Thank you for the help @KubaPL - confirmed Windows 10 is playing my Blu-ray again (SE-506CB/RSBD).
Running local admin - installed and tested using Leawo free bluray player.

Note most player's now required Java SE Runtime to display menus (this requires registration with Oracle as NOT the standard browser plugin version.
Explorer

hi friend

 

my bd burner still no working with windows 10 build 1903 using local admin account, windows detects drive but no disc, burnaware 12.4 with admin permissions it detects unit but no disc, so can't do anything....

 

i use original cable and verbatim bd-r recordable like this

 

can u post your pc specs and windows config? thanks

Observer

I have this model I bought many years ago, still working as expected without problems, including Windows10

Details:

- SE506BB/TSBD F/W-TS00

- I never used it to watch BD movies, just to write/read in BD data for my backups

 

I supsect that some part of people having trouble probably because got reach the maximum ammount of times you're able to change region for BD protected movie disks. You can check how much changes are left by going to Device Manager->DVD/CD-ROM drives->TSSTcorp BDDVDW SE-506BB USB Device->right click->properties->DVD region and check "Changings remaining". If theres any change remaining, you're stuck with the last selected region to be able to play such protected disks. My drive have 5 changes yet to be used, as I never used it to play movies.

 

- I Wonder: If theres any chance of a bug in this part, that's, if you reach the maximum ammount of changes the drive will block any disks, even writeable ones. Perhaps that's a nice information to test ammong defective drives to reach  a conclusion about this.

 

- Unfortunately I have seem in the past DVD movie players (including software players) that will change the region automatically without asking.... also people just go pressing OK without reading the message sometimes.

 

Salute!

Explorer
hi @RodrigoNH

thanks for your toughts and comments.

first, it seems no the same modeldrive with the problem (SE-506CB) .... in my case, as you, want the drive just for backup, so, the dvd region changes remain in zero, but we described in this forum, even bd-r discs appears on windows explorer....

i tried downgrade firmwarea and test with earlier version, but no, result, maybe need to test with differents media but here when i live, there is no bd-r media, just buying online, but it getting expensive to buy differents brand or types.

in the past, exist a online store called supermediastore.com that sell a sort of brands of all the world and it sold sample packs for different type of media.

my theory is that entertainment industry leaders make an agreement with bd-r developers, or microsoft, or some leading brands to stop production and existing bd-r units and media for stops piracy....

i'm glad your unit works for burn at this days, take care for it,.....

greetings...
Top Liked Authors