Support

Open search

Samsung C24GFG70 Curved Gaming Monitor Problem

Highlighted
First Poster

Hello, my name is Pieter and i really need some help with my monitor.

I have the Samsung C24FG70 Curved Gaming Monitor and it is a really good monitor and i'm happy i bought it but since a couple of months it started to annoy me. Not the quality and the performance but something else. When i turn on my pc i first see the BIOS menu screen, in the top left corner i get the 'output source message' which indicates what cable i'm using to connect it to my pc. I use displayport because of the 144 Hz refreshrate. When its done with loading the BIOS-screen, i get that same 'output source message' again when im ready to log-in into windows. After i logged in i get that message AGAIN. But the worst part hasn't started yet. I play a lot of GTA 5 and mostly GTA Online in Fullscreen mode to get the best performance out of my GPU. Every single time i press ALT+TAB to switch from the game to my desktop, the screen goes dark for about 3 seconds and then i see my desktop but that irritating "Displyport source message" appears again. Then when i switch back from my desktop to my game, the same thing happens: again the delay, the dark screen and that stupid message. In the past i didn't had any problems with it and i didn't  saw that message and alt+tabbing out or into a game went smoothly.

 

Can somebody please help me because this really really anoys me.

My pc-specs are:

Gigabyte GA-AX370 Gaming K5 Motherboard

AMD Ryzen 5 1600 CPU

Nvidia MSI GTX 1070 Gaming X 8GB GPU

Corsair 16GB DDR4 3000Mhz RAM

Be Quiet! 600W PSU

Kingston 120GB SSD

WD 1TB HDD

 

With regards,

PieterVO 

9 ANTWOORDEN 9
Black Belt 

Good afternoon @PieterVO and welcome to the Samsung Community! I'm guessing it's the Freesync function that keeps popping up. Since Freesync is a function which works with AMD cards, it's irrelevant to your NVIDIA card. As the manual says "While you are using the FreeSync function, the screen may flicker due to variation of the output frequency from the graphics card." So that's probably what's happening. Could you turn Freesync off in the monitor menu? I'd love to hear if this fixed your issue.


---------
Signature_Note9_Trans
"I'm just trying to make a buck, like everyone else."
- Tom Waits
First Poster

Hello @JoeriS Thank you first of all for the suggestion but it didn't help. My problem is that everytime i start my pc, the "displayport" message appears in the top left corner of my screen. This happens 3 times in a row before i'm even on my desktop-screen. When i start up GTA V, the "displayport" message in the top left corner appears again. When i ALT+TAB out of the game, it takes a couple of seconds before i see my desktop and during that amount of seconds its just a alluminated black screen. When i'm finally on my desktop, that irritating "displayport" message pops up again. When i ALT+TAB back into the game, it takes again that (long) amount of time before the black screen disappears and AGAIN i get that "displayport" message in the top left corner of the screen. You could describe it like that your PC is searching for a outputsignal each time you go out or get into the game or when your booting your system and the different loading screens appear, the same thing happens: searching for a signal while its already connected.

Black Belt 

That's why I immediately thought it could be the Freesync function since it detects the change in frequency, which would happen if you switch between BIOS/desktop/game. Freesync also overrules your chosen Hz setting, switch this off and you can select the 144 Hz so the monitor will only use this frequency.


---------
Signature_Note9_Trans
"I'm just trying to make a buck, like everyone else."
- Tom Waits
First Poster

I have just tried what you said and it doens't work saddly enough. Do you maybe know something else how i can make that irritating message stop from popping up in the left top corner. It just lookes like the PC or the monitor is detecting the same input/output signal over and over again. I have it connected through Displayport because of the high refreshrate option but it even happens in HDMI connection.  Could it be a problem with the drivers or something, or is their a way maybe to reset the monitor? Or can i maybe turn-off the message that displays the monitor's source?

Black Belt 

It's always a good idea to check your videocard drivers in a case like this, and check its settings if there's anything on there that has any impact on the refresh rate. As far as my gaming experience goes, I've always had AMD cards so I can't really help you there. But I believe NVIDIA has something similar to Freesync, maybe turn that off (if it's on)?


---------
Signature_Note9_Trans
"I'm just trying to make a buck, like everyone else."
- Tom Waits
First Poster
The video card drivers have nothing to do with this. He just wants to turn off the icon that pops up on the top left of the screen every time you press alt+tab. I am using a Samsung C24FG73 and it is the same thing:
1. Go to a game in fullscreen
2. Press alt+tab
3. A blue-ish field with your connection (e. g. HDMI 1) appears
How do I get rid of this field - the message?
I set video source to manual. Freesync is off. Connection is via HDMI 1
Nick Moderator
Moderator

I get what you're saying. I'm not a 100% sure the message can be stopped, but I've send an email to the right person. Hopefully we'll get an answer soon!


---------
Signature-Note10
"Changes call for innovation, and innovation leads to progress"
Nick Moderator
Moderator

I wasn't sure, but the answer solidifies my thoughts. It's normal that the monitor does this. It happens with every 'change' in signal, which happens during the starting up process and by using the alt-tab command. The delay only happens if you use full-screen, not while using windowed full-screen of windowed. 


---------
Signature-Note10
"Changes call for innovation, and innovation leads to progress"
First Poster

I was having a similar problem. For me, when I use displayport, and trun off the PC, the minister will show the bios message in the top left corner. I believe it's fine to show it once, but my problem is the monitor never goes to sleep properly. It will cycle between this message with the backlight on, and sleep mode, forever. Interestingly enough, with HDMI it goes to sleep right as it should. I'm Iist curious weather or not this is normal behavior.