Support

Open search

Sky Q & HDMI Surround Sound Setup

First Poster

I have tried factory resets, new cables, a diffrent TV just nothing seems to work. At present i am using the Sky Q 2TB box (direct cable connection.) - My gut feeling is the problem lies within the software.

 

 

The problem lies with the TV and soundbar searching for a source automatically. (the ARC source seems to be the pre-programmed default)

So if you where using the HDMI source on the soundbar to use SKY Q and then turned  everything off. The next time you turned the units back on you would think it would stay on the same source. This is not the case - it will automatically default back to the ARC source.

 

If there was an option within the settings where you can choose a default HDMI port where the soundbar would only read from this ie. HDMI source and not ARC. this would resolve the issue. It would avoid the soundbar automatically looking for a source/picture to play.

Apprentice

Have you tried turning off anynet+ ?

also make sure hdmi control on the sky q is set to ON

Apprentice
You have to turn the speakers off directly from within the TV, once off they stay off until you reactivate.
First Poster

I am having the same problem. Sky q to hw n950 soundbar via hdmi1, then soundbar to TV via hdmi arc. I have to connect this way to be able to listen in Dolby atmos when available. I switch everything on with sky q remote. Everything fine for approx 20 seconds then defaults back to TV arc, so I have to press home button to get back to hdmi 1 source and everything is fine. A bit annoying. 

First Poster

I know its so frustrating!

The problem I feel lies within the software. There needs to be a way/option where you can specify that it will only look for the hdmi port and nothing else.

Apprentice

I have the exact same issue with my Sky Q box connected to HDMI on the sound bar.

 

I sometimes see a blue screen from Sky saying something like "This display does not support HDCP" and when I put the Sky Q box into standby, I hear about 3 seconds of audio from Sky before it powers off. 

 

I believe it's a HDMI handshake timing issue between the Sky STB and Soundbar. There's a 40 page thread on Sky's community website complaining about the same thing on different TVs and Soundbars so I don't think it's a fault with the N950.

 

Until now the only fix was pulling the plug on the Sky box, but I've found a workaround which has so far worked every time:

 

When you start watching Sky, make sure the TV & soundbar are switched on BEFORE you power on the Sky box. When you stop viewing Sky, put the Sky box into standby before doing ANYTHING else like powering off TV or switching inputs to Blu-ray, streaming/gaming device or TV ARC. 

 

I have also stopped using the Sky remote to power on the TV and Soundbar, but still use it for volume. And I replaced the Sky supplied HDMI cable with pink connecter with a different high speed cable. 

 

My TV is a LG OLED B7.

 

 

 

 

First Poster

I had a similar problem and solved mine by plugging the amp HDMI ARC out lead into the TV HDMI 1 (not the arc imput on the tv).

New Member

Hi l was having same issue driving me mad. Solved this issue throw away the sky hdmi so DO NOT use the sky hdmi cable

 

new non sky hdmi cable from sky q to tv hdmi

non sky hdmi cable from soundbar arc to tv arc

 

all sorted hope this helps

Top Liked Authors