Support

Open search

Samsung Multiroom Tidal Log-in Issue

Highlighted
Explorer

My previous post about this got flagged as Spam by some overly sensitive member for some reason (maybe they got a phobia of criticism?).

 

Anyhow, since yesterday, I have been unable to log-in to the Tidal music service in Samsung Multiroom?

 

It was working fine in the morning, then later in the day, "Invalid ID" message when trying to launch a playlist.

 

Has anyone else had any log in issues with Tidal and how was it rectified?

 

I've so far

  • Uninstalled and re-installed the Samsung Multiroom app
  • Reset all 10 x R360 speakers
  • Changed Tidal password via their own website (so I know it's valid)
  • Reset router to factory settings
  • Used a different device (Galaxy Note 10 Plus 5G and Tab3)

Yet, still I get the "Invalid ID" message when trying to play music using the Tidal service integrated integrated into Samsung Multiroom.

19 REPLIES 19
Highlighted
First Poster

@Ripperoo wrote:

My previous post about this got flagged as Spam by some overly sensitive member for some reason (maybe they got a phobia of criticism?).

 

Anyhow, since yesterday, I have been unable to log-in to the Tidal music service in Samsung Multiroom?

 

It was working fine in the morning, then later in the day, "Invalid ID" message when trying to launch a playlist.

 

Has anyone else had any log in issues with Tidal and how was it rectified?

 

I've so far

  • Uninstalled and re-installed the Samsung Multiroom app
  • Reset all 10 x R360 speakers
  • Changed Tidal password via their own website (so I know it's valid)
  • Reset router to factory settings
  • Used a different device (Galaxy Note 10 Plus 5G and Tab3)

Yet, still I get the "Invalid ID" message when trying to play music using the Tidal service integrated integrated into Samsung Multiroom.


Same here!

Highlighted
Apprentice
Same problem here with iPhone, Android and Mac Multiroom apps. I was logged out of Tidal by the app and when I try to log in it tells me my "invalid ID" message. My ID is not invalid as I can log directly into Tidal with no issues.
Highlighted
Explorer
Anyone fixed it or got any sense out of Samsung or Tidal?

I bet some Samsung have let some time-limited agreement/licence expire and they don't want spend money renewing it as Samsung Multiroom is "Old Tech" to them!

I just hope to hell I'm wrong and it's just a glitch, but something isn't right, because first off Samsung broke Deezer in May 2018 with the last firmware update, making it virtually unusable in some instances (newly created playlists wouldn't launch) and more recently a lot of users have experienced log-in issues in the last few weeks.

Now Tidal?

We need someone from Samsung to interject here with some definitive information.

Do they even look here?

Probably not as it's just a "Community Forum" and neither worth their time or effort!

They've already got our money after all.

In my case, over £2000 UKP on Multiroom speakers and in excess of £10,000UKP (probably closer to £15-20,000 in all fairness) on other Samsung products (TVs, Phones (x 10+), Blurays Players, DVD Players, Kitchen Appliances) over the last 15 years.
Highlighted
Observer

I have the same issue with my multi room, I take it Samsung have not replied to any of these replies?

Highlighted
Explorer

I've just spent (AKA wasted) over an hour of my life chatting to Samsung Customer support who as always say they have no reported issues of this kind.

 

The thing is that it's easy for them to say as no-one knows who else has contacted them about the same issue.

 

I'd suggest that if anyone has this issue, go to https://www.samsung.com/uk/support/livechat/

 

Select "TV & AV" and continue from there.

Chat support is only available 9am to 6pm (7 days a week).

 

This needs to be sorted as Tidal is not inexpensive @ £20 per month.

 

I think I'm gonna ditch this Samsung garbage and invest in a SONOS system instead as even though it is more expensive, at least it will work as intended.

 

Samsung: Nice Hardware/***** Software

 

Highlighted
Observer

Well the live chat was a waste of my time, 10 minutes wait I was told, over an hour later no contact.

asked if I was going to talk to someone and no reply, very very poor service.

Highlighted
Navigator

Yup same here. 

With all the problems I went through with Samsung TV and sound bars I will never ever buy anything audio video related from them, especially audio as no one will help you with your problem.

This is sad since R3 radiant speakers are a really nice pair, but Samsung doesn't really care about their audio branch or multiroom app anymore. 

 

Let's just hope it's something on Tidals side cause if it's Samsung related they aren't going to fix it. 

Highlighted
Explorer

@

That was unlucky.  I got through almost immediately.

 

Did you select "TV & AV" again in the chat window and fill in your name and email and such?

After I did that, I was asked for a model number of my device, so entered:

WAM1500

WAM3500

WAM6500

 

When the AI assistant replied, I typed "Chat to an agent".  Not sure I needed to do that bit, but got through within seconds, then was on there for well over an hour.

 

Maybe I tired Marrielle out and she's gone for a lie down.

Highlighted
Apprentice

Tried speaking to chat - thanks for the tip about "chat to an advisor" otherwise I'd have been stuck chatting to a bot!

 

I don't think there is much they personally can do but I asked them to escalate the bug to their app engineers as we can't use our speakers until it is fixed. 

 

I'm so disappointed with the Samsung software experience. The speakers are great when they work but I've had so many issues with the apps (last was after Android updated and the Android app wouldn't open for months).

 

Anyone know if spotify premium still works? I got a 6 months free trial from a Currys promotion but don't want to use if it up yet if the login is broken in multiroom too.

Top Liked Authors