Open search

J7500 Soundbar not working

First Poster

I have a J7500 Soundbar that was working fine with my Series 9 TV, connected via TV Soundconnect with no issues for the past few months since purchased.


2 days ago it stopped automatically coming on with TV Power on.  I would have toturn it on using the remote and it would then connect and work fine.


Yesterday the remote stopped working intermittently and then the buttons on top also stopped.


Today I am able to power on using the remote but nothing else.  Buttons on top of soundbar similarly do nothing except power on/off.  Volume and source buttons do nothing on either remote or device itself.


I'm unable to connect it to the TV, have tried disconnecting from mains and resetting TV sound settings but no joy.  I haven't been able to try an HDMI connection purely due to the built-in setup, it is not easy to run new wires.  I would like to get back to it working via TV SoundCOnnect like it used to.


Any suggestions welcome.

Thanks in advance


Have you tried solving it using the Samsung multiroom app? Go to 'speakers' on the app. Select soundbar and choose 'source' (third option) and choose [TV] Samsung 9 series (wifi)? Also make sure you update your speakers via your settings on the multiroom app. 


On your tv: try going to your sound settings, choose 'select speaker' (it's soundbar wifi). Also make sure you update speakers via your setting on the multiroom.


All my speakers work via wifi and it  works great as long as you keep udating it regularly (weekly) via the settings on the multiroom app. 

First Poster
Hi Enzo. Did you solve your problem. My system which is identical has just developed exactly the same problem. I have everything to fix it but without luck. Did you manage to fix yours?

First Poster

Hi ChrisSam


I called Samsung support and they put me onto a local service centre who repaired it FOC under warranty. Apparently the circuit board in the soundbar was faulty and they replaced it. Thankfully, no issues since . Worth a try. 

First Poster

I know this is an old post. I had the same issue. ARC failed. Had engineer's out and everything. I found the issue to be an Amazon fire stick. Only when I have that plugged in to TV it has the issue. Unplugged and reset the tv and sound bar and never had an issue again till I use the fire stick. 

Top Liked Authors