Open search

HW-N850 Won't Pair with SmartThings


I have the same problem, using Iphone X with latest IOS version. The app found my N850 bar but aftert 16% it stop working. It would be nice to know at least if this is a problem of the app!! or a technical problem of the soundbar...

I bought the bar just 2 days ago...  maybe the App needs to be upgraded, ok so far... but somebody from the support might tell this to the customer.

Concerning Atmos support, it only works with configuration Xbox, Ps4 oe Apple TV connected to the Soundbar and from there by HDMI into the TV. I was told that actuall ARC does not support Atmos, so you need to connect all your devices which supports Atmos, directly into the soundbar where it decodes the Atmos signals. For Pass through from TV, there is not enough bandwith. It will work with new 2.1 HDMI standard later on. Thats what Samsung Support here in Germany told me a couple of days ago.


Samsung Support can be flakey. I spoke to three different people last week who told me three different things. One of them told me that Atmos can work as long as the soundbar and the TV are connected via the ARC, which when i tried it didnt work. So i connected my Xbox and Apple 4K TV directly to the soundbar, ARCd the Soundbar to the TV and it worked. I get the dolby atmos notification come up on the soundbar and the quality is great. It just isnt made as clear as it should be - thats my problem with all Samsung products.


In terms of the SmartThings, yeah, excatly the same problem. Its odd as i cannot search my soundbar but the app detects it so i end up being able to add it like that. Like you, it gets stuck on 16%. 


DOes anyone know if the MU8000 supports Dolby Vision?






Just checking back in as there's been a few updates to the app since I last tested;


No improvement, still fails at 44% with "Device is not responding".


You’d like to think they test these updates. 


Seems I have solved the problem with the Smart Things App by myself, by accident.


I disconnect the soundbar from electricity for about 5 minutes.
After replug, my wifi was found by the Smart Thing App and i was ask for the password which I put in and it was accepted. But now the registration stops at 98%, before it was 16% without WiFi localization.
Then I logged out of my Samsung Account in the Smart Things app, restarted my phone and logged back in.
Now suddenly the App ask for "permission" concerning my Samsung Account ???
2 options:
“Remove already registered account” or “request authorization”
I click on request authorization as I only have one account which I just created, the Soundbar is brand new! ...  but no reaction!
Then I use  the other option “Remove already registered account” and suddenly it works…
Everything is registered and running, at least since yesterday lol.

Looks like the whole problem is related somehow to the Samsung account !

I  think this problem should be noted more detailed somewhere in the manual, troubleshooting etc.
I was already about to give it back and buy other brands bar…
However in my case everything is fine now. Hope I could help with my experiences.

(Sorry for maybe not correct English, I am German)


BTW, does anybody know if it is in general possible to switch with the Q9FN TV remote the sources on the Soundbar (HDMI1 / HDMI2 / WIFI etc.) I cannot find this function even though I have registered the TV remote control as Universal remote. Unfortunately I always have to use the original plastic remote to switch sources of the N850 Soundbar and still have 2 remote controls, although volume selection etc. can be regulated with the TV remote control.

First Poster
I have exactly the same problem as others.

Thanks for the post I will try this tomorrow.


I will try this again too.


As per another users comments, same problem with the remotes. I would prefer the one Samsung TV remote to control everything but cant do that - i can control the volume of hte soundbar and thats just about it. Cant change the source on the soundbar?


Not to shoot anything down, but I tried the "power everything off for a few minutes" thing in the first place and it didn't help, nor did nuking the Samsung app and all stored data.

New Member

Having same issue trying to add my MS650Soundbar via latest SmartThings app on Android ( via Galaxy S9 plus).


Disappointing, and hardly “ smart”.

First Poster

I have the exact same issue with the HW-N850 SOUND BAR. I can't connect it to the smart things app as it stops at 44%!! With same exact error. Helpppppppp. I'm also using a OnePlus. Mine is a one plus 5T.

Top Liked Authors