Support

Open search

HW-N850 Won't Pair with SmartThings

Explorer

This soundbar refuses to pair with my network via WiFi. I downloaded the app (which requires far more permissions that is acceptable, btw) and tried to pair it. It gets to 44% and then fails saying that "Couldn't add device. The device isn't responding". I've tried several times, I've even tried on both my 2.4Ghz and 5.2Ghz networks, same result.

 

It shouldn't be a "weird password" issue; My WiFi password is only 9 characters long at the moment which is 1 more character than the absolute minimum, so that's not going to be the cause, it's also only letters.

 

I've reinstalled the app. I've also just installed the firmware update that appeared the other day (although it had no changelog so no ideas what that changed) but that hasn't helped.

 

Any ideas what may be the issue?

59 REPLIES 59
Superuser I
Superuser I

Try to reboot the soundbar and your phone at the same time and retry it.

I know that SmartThings requires a lot of privelages, this is because its an app for litterally everything (One that rules them all). I personally accept it because its from my phone manyfucturer (And considering I'm the costummer, I trust them ).

 

 

Explorer

Rebooting both didn't help. It pairs via bluetooth fine, but it just refuses to add in the app. I start the app, it says it's detected the soundbar and do I want to add it. I say yes, it takes me to a Samgung page where I have to click agree, it then goes back to the adding window and that starts the progress meter. It gets to 44% each time and just says "The device isn't responding".

 

Screenshot_20180905-222136.pngTakes a few seconds to each 44%...

Screenshot_20180905-222200.pngThe spinner changes from blue to green, it spins a few more times at 44% then fails.

Superuser I
Superuser I

I have taken a look at the manual:
http://downloadcenter.samsung.com/content/EM/201807/20180719105359046/AH68-03046E-01_HW-N850_XU_ENG_...

Can you follow the instructions on page 16/17 (16 is for bluetooth, Just in case )?

 

Edit: Here is a better manual (Page 22):

http://downloadcenter.samsung.com/content/UM/201807/20180716102743533/HW-N850_XU_FullManual_00_ENG_1...

 

Make sure that you are on the same wireless network as the soundbar.

 

 

Explorer

Page 16 in the first link is just pairing the soundbar to the phone using bluetooth. That works and I can play music over bluetooth from the phone to the soundbar.

 

The bit that doesn't work is page 22 in the second link you posted (which is painfully barebones). It's during that setup which gets stuck / fails (as per the pictures above).

 

And just to show I'm not doing anything silly, here's a video of the whole process - https://xnode.org/files/SamsungWifi.mp4

Superuser I
Superuser I

I assume that you are on the same network as the device? In that case I ran out of ideas unfortunately. Perhaps a moderator might be able to do something for you. 

 

Personally I had the same issue with my TV yesterday (on 33%) the solution was resetting the sound settings. 

Explorer

Well the soundbar isn't on any network at the moment, that's what SmartThings is supposed to set up. But they're both in the same room so the app should have no problem getting the soundbar to connect to the same network that the phone is using.

AntS Moderator
Moderator

Cheers for your efforts on this one @SjorsK

 

@Enverex:  I asked the SmartThings team, and they're currently looking into a report of something similar (with a washing machine rather than a soundbar though). I'll let you guys know of anything I hear back from them on that in case there's a common cause and/or any useful advice that'll apply in this instance too. In the meantime, if you (or anyone else) does happen to stumble across a solution, definitely let us know in this thread.


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.

Apprentice

Hi,

 

@AntS: Any update from SmartThings team?

 

@Enverex: Do you still have the same problem? I have exactly the same problem with my brand new HW-N960 and SmartThings app (1.6.15-178):

 

- I'm able to pair my soundbar and Apple iPhone 8 (iOS 12.0.1) via bluetooth and play music from phone to the soundbar.

- SmartThings app detects the soundbar when phone's bluetooth is switched on. When I try add it, the meter gets stuck to 16% and I get the same error message as you: "Couldn't add device. The device isn't responding. Try adding the device later." As in your video, I have also the option "Add device manually". Using that, I get stuck to 44 % with the same error message.

- In addition, SmartThings app tends to crash 2 times when I start adding the device. The app just shuts down. I start the app again and same thing happens. Usually after the second restart I'm able to start adding device. I have re-installed the app and the behaviour is still the same

 

I wonder if the problem might be in SmartThings working with iPhone and/or it's new iOS? What phone you are using?


@Enverex wrote:

Rebooting both didn't help. It pairs via bluetooth fine, but it just refuses to add in the app. I start the app, it says it's detected the soundbar and do I want to add it. I say yes, it takes me to a Samgung page where I have to click agree, it then goes back to the adding window and that starts the progress meter. It gets to 44% each time and just says "The device isn't responding".

 

 

AntS Moderator
Moderator

Hi @Nikke. I've not heard anything back from them on this one, so I've sent them an email to see if there's any progress on it from their end.


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.

Top Liked Authors