Support

Open search

HW-K650 and Two R1 Wirelss Speakers in 5.1 With KS7000 TV

Pathfinder

Hi PJ - Thanks for the info. Will give the soundfile a play when I get a chance and see how it goes.

 

i have found a bit of an issue that I cannot figure...

 

I had my soundbar connected through HDMI Arc, with a bluray player and then connected in my 2 R1 speakers using the create surround feature through my TV and BluRay player over wireless. This was not a problem when playing/viewing TV from Sky/TV. However, when I then played a DVD/BR and selected Surround as the option the screen blanked, and generally the entire system baulked - requiring the BR player to be turned off to reset the system.

 

I have since disconnected the HDMI lead between the player and the soundbar - connecting the player directly to the TV and bringing in the soundbar and 2 x R1s on wireless only - which seems to work fine. Just a bit concerned I am now missing something audio wise?

Navigator

H all

 

I've got the following..

Ks658000 TV

Ms750 soundbar

R3 speakers for surround

700 Samsung subwoofer.

 

I've currently got hdmi arc in from soundbar to TV..

 

How do I set up the r3s as surround while in hdmi arc?

Dont want to use wi-fi for everything cause it's so unreliable. 

Thx

 

 

 

Pathfinder

Hi Rich,

 

I don't think you can. To set it up for surround I think you have to connect all three together wirelessly as a surround sound group - you cannot connect the soundbar as an arc connection then the two speakers to work with it on wifi.

 

To be honest apart from the odd glitch I haven'texperienced any problems - the only thing I have found is in surround mode you cannot select sports/movies etc - it is just surround.

Navigator

Yet that'sanother problem that you can't select movie music mode etc..neither can you select surround or use the upfireing speakers....

I've heard about using optical aswell but how would that work with the r3s...

 

Bit of a ***** product really always some limitation! I mean this is 2018 and I've spent thousands on this Samsung tech.

Navigator

Hello, 

You can connect R3s in Samsung multiroom app for Android or PC (pc one is *****).

In that app click on three dots near Ms750 and click "surround" or something like that (I have it in my native language so not sure what's there in English app) then drag your R3s to the left and right rear channel. You can also adjust volume there, put them both on +6.

 

If you have ms750 with the additional subwoofer I strongly recommend you to get dedicated Swa 9000 rear speakers. Theres a mismatch in volume levels with MS Line Soundbars and R3s, and you lose all the additional options for the Soundbar on your remote (like surround, movie etc, even treble/bass settings won't work), so you won't even get those virtual height channels to work. It all works with Swa 9000 speakers, and since you already have the sub you won't need additional wifi dongle.

Also adding subwoofer changes Soundbar's crossover, so I guess it will all be messed up with R3s as rears. 

Navigator

So if I buy the swa 9000 rear speakers,how does it connect as a surround ( WIFI ? ) as my soundbar will be in hdmi arc ?

 

Do I still have to use the multiroom app and group them together ?.

 

 

 

Thx for all the replays much appreciated 👍

Navigator
You just pair it with the Soundbar the same way you did with Swa 700 sub. They use the same wifi dongle and connect directly to the Soundbar, so the whole thing - ms750+SWAW700+SWA9000 works together as one.
You can increase their volume or even turn them off via your soundbars remote. They automatically power up with your Soundbar.
It's all in the manual, very easy to set up and works every time unlike R3s.

I still have my R3s right next to Swa 9000. I have them paired in stereo mode, and listen to music with them, I think they sound great, but thanks to Samsungs "great" coding and software support he whole experience with them as rears is just way too annoying.

Oh and and one more thing. This was game breaking for me.
If you use R3s as surround with Soundbar plugged in via hdmi ARC or Optical there's a huge lipsync issue. Something around 200-250 ms delay that you can't adjust.
If you connect the Soundbar and R3s via wifi the delay is still there, but not as annoying (around 80-100ms),but with wifi connection it won't play DTS5. 1.
Multichannel DTS only works with HDMI for some reason.
Navigator

That sounds more like it plug and play.....

Yer I've noticed the Lipsyc bloody annoying..

 

Well gotta try and convince the wife lol...

Only had the r3s for around 2 months and never hardly used them cause if the bloody WiFi drop outs,the soundbar via WiFi is ok, might take them back to Currys and say they just don't work.

 

Thx for quick reply much appreciated 👍

Pathfinder

Hi Guys, 

 

Remember me! How are you guys and your K650? 

 

Not been on here for a while as mine has been working fine with little issue. I recently changed from by BT Home hub to a TP-LINK router to get more signal distance, but now having big issues with connection and slow volume change, so may have to revert back to the BT Hub. I think it's an issue with 2.4ghz as it doesn't have 5ghz which is what I had the BT set up on. I think this just goes to show how important the router is in all this. 

 

Started to notice a small glitch on Netflix too where the sound skips for half a second. 

 

Pathfinder

Got a 650 with 2 x R1s hooked up - with no major issues. Occasionally I have to reset the 650 as the TV fails to find it on the network.

 

I moved the R1s and 650 onto the 5ghz (BT Router) channel as most of my other kit is on the 2.4, so wanted to separate the speakers into a dedicated area. I was getting the odd sound skip on the 2.4, but normally this would only occur when watching a bluray - not on any streaming service.

Top Liked Authors