Support

Open search

HW-K650 and Two R1 Wirelss Speakers in 5.1 With KS7000 TV

Apprentice

one last assist plz, other than the very expensive sub samsung offer to match the ms 650 are there others in there range ( or anybody elses) that could work with the 650?

thx

Navigator

No, ms650 only works with swa-w700 sub. It's expensive but iveI read it is really good.

 

Also if you have ms650 you might consider buying dedicated rear speakers for it, swa-9000. They should be less problematic than radiants, and you can use the remote to control them. They are also cheap, i think they cost less than a single r6

Apprentice

many thx for the steer, appreciated.

New Member

Not sure if this is new information or not, but it looks like when the system is powered down it 'forgets' the custom levels... however the sliders in the app and on the TV stay the same. So it looks like the rears volume has been boosted, when actually the soundbar and rears are at 0.

 

I find selecting 'reset' the sliders go back to the middle and the sound stays the same. Now you can reduce soundbar levels and increase rears, resulting in much more acceptable rear levels in my opinion.

 

Frustrating that this has to be changed every single time the system is powered down/the TV is turned off, but at least I now have a workaround.

Apprentice

Thanks for help so far chaps, so after buying just the 0ne r6 then realising i needed 2 rear speakers i returned it and purchased 2 r1s, so all connected and working.

Sounds quite good so far however would appreciate valuble insight from those that have helped create such an intersting forum so far.

So tv is a samsung 8 series sound bar originally connected to Tv via Arc input using a hdmi, this lead is still pluggesd in the back. Guess it can stay there?

So  i seem to have connected my 3 speakers to the tvs wifi as opposed to connecting each individual speaker to the router. Is this an acceptable way to go or should i reset the speakers and connect individually to the router?

When i group the speakers ms650 controls become non funstional, eg bass/smart/surround/music/pop etc is this normal?

they also disappear on the app , the app tells me to disconnect from the tv to play music as an example, any help greatly appreciated

thx

Keith 

Apprentice

should have mentioned when all 3 speakers are working together the 650 shows its in wifi mode when on hdmi/arc only soundbar works.

thx

Navigator

If you want to get surround via HDMI you need to pick soundbar in tv settings and manually add surround in MULTIROOM app. I'd recommend you to stick with WIFI setup you just did because it has perfect lipsync, with HDMI you will get lag you can't adjust if you add rear speakers. 

Be sure to set your TV to "Dolby Digital" in sound options. With MS650 you can also get DTS 5.1 but it doesn't work via WIFI, you need to use the HDMI method, and change to DTS in TV settings.

 

If you are watching Netflix, Amazon, Showmax or TV it is all in Dolby, so you can just leave it with WIFI setup. You should also raise your R1's volume to +6 either in TV surround settings or in Multiroom, because they are too low. 

Navigator
>When i group the speakers ms650 controls become non funstional, eg bass/smart/surround/music/pop etc is this normal?

Oh about that. yeah that's what happens with Radiant speakers as rears. That's why i was recommending you to get dedicated SWA9000s speakers, you can control them with your remote and also change soundbar settings. I guess after HW-K650 and other K series soundbars, Samsung realized that Radiant speakers as rears are just too problematic and MS line just got a dedicated rears that you connect to the soundbar with a wifi dongle, and not your router, so i guess they have no lag.

If you want more bass though, just power up the soundbar first and set the desired bass level and then power up tv.
Apprentice

wow , really good stuff , many thanks!

Apprentice
i will keep the wifi settings I think as you advise, it seems the most elegant solution, is there a technique to getting it working with an echo dot? I have asked Alexa to add new speakers (which I have renamed as per Alexa skills instructions) but nothing seems to be found?
thx
Top Liked Authors