Support

Open search

HW-K650 and Two R1 Wirelss Speakers in 5.1 With KS7000 TV

Pathfinder

Just one more thing. Can you please supply me with a contact number or email address for the below please:

 

Sean Archer the senior customer services executive

Pathfinder

Hi Tater,

Sorry should be helping you a bit. 

On the subject of manual update it didn't work for me. You will need a USB stick and a micro USB extension cable with a female socket. Guide to manual install can be found in the K650 manual.

Very easy to do. Download, extract, plug in to the service socket and switch on sound bar........ Should display update on Lcd display.
Didnt work for me. The software currently on the Samsung web site is old, it's 3107 from the 1st September and won't accept it as you can't roll back the firmware to an earlier version.
Interesting that they haven't got the 3108 onward firmwares that are causing all these issues.

Pathfinder

Hi guys. Also just noticed if you turn off the two R1's or whichever speakers you have, and connect only the sound bar it returns to original awsome sound quality. 

 

You will need to go to expert sound setting and increase the bass setting as mine was set to minimum as standard on movie mode. 

 

This doesn't fix the surround sound issues when using radiant speakers but is a temporary fix so unit can be used until fix. 

 

Also interestingly this is still connecting in multichannel mode without leads, so it doesn't appear to be wifi sound input that's causing the issues, it's specifically the part of the firmware that operates in full surround mode when the radiant speakers are attached, which also restricts any user settings of sound modes except for sub woofer (all others disabled) 

 

Samsung. I have also noticed that when just the soundbar is connected and you go to manual equaliser settings through the tv menu, this also has a jump from -6 to -12.

 

Could the minus 12 setting be anything to do with night mode in the app and not part of the sound quality issues??? 

 

 

First Poster

Hi guys I've recently bought this same setup following black Friday and am waiting on stock of the HWK651. I'm very concerned by this whole thing and am now wondering if it's best to return the sound bar and rear speakers and buy a more traditional setup with av amp. 

 

Since this issues seems to start following a firmware update. Is it possible to stop the soundbar from updating once setup. As it seems to what from everyone is saying work fine out of the box in surround mode. 

 

I'm due delivery next week so would be keen to know before then. Already have the tv which im very happy with. 

Pathfinder

Hi. 

 

You can turn off auto update in the Samsung multi room app. 

The only problem you may have is the wifi issues (which where resolved with a previous update)  may be present in the factory firmware, and trust me you don't want those issues either. I suffered with continual dropping out of wifi, and having to constantly reset everything almost each day. 

We are currently on 3108 and this appears to be the problem update with regards to using the radiant speakers in surround mode. 

You can download the 3107 firmware from the web site and do a manual update from memory stick leaving auto updates turned off, but I can't say the sound issues aren't present in some form in the 3107 firmware.

Without the firmware issue it's a great peice of kit, but unfortunately ruined by an updates and further denials of Samsung there is even an issue.

Hope this helps.  

 

Explorer

Not much happens at weekend so I'm going to give Samsung this week to at least give us a progress update.

 

as long as they accept there is an issues and are actively working on it I'll stick with them. But I don't have long before my month is up.

Highlighted
Explorer

Satty, If it were me, I would return it. I don't feel confident this will be fixed anytime soon.

Pathfinder

Agree with Bryanty........... This sound issue has been going on for almost 3 months for me and still no closer to them even admitting the firmware problem let alone fixing it. 

 

Trying to keep some impartiality but it's impossible. 

Explorer

Robbienobs, I also noticed this a while back. If you go into expert setting on the TV and set the surround speakers to NONE then the sound through the soundbar returns to its original good quality. there is a minor issue with that however. when running it this way the sound on my soundbar is pretty loud. for example i have to keep the volume level on 3-4 when casually watching. If at that point go back and add the surrounds back in you have to turn the sound up to like 40 to hear the bad sound again.

if you use the soundbar through TV Connect (bluetooth mode) then the sound level is usually on 25-35 for casual watching. Curious if you notice the same thing.

Explorer
7 months for me. I first reported this in the US forums in July.
Top Liked Authors