Support

Open search

WLAN schaltet sich bei Android 9 scheinbar ab, wenn der Bildschirm ausgeht (S8+)

Pathfinder

Ich habe neulich mein Samsung Galaxy S8+ auf Android 9 aktualisiert. Seitdem ist mir aufgefallen, dass sich das WLAN scheinbar abschaltet, wenn sich der Monitor ausschaltet bzw. das Gerät gesperrt wird. Die genauen Umstände sind mir nicht klar, aber auf jeden Fall, sobald das Handy nicht benutzt wird. Möglicherweise dauert es aber auch einige Zeit, bis das passiert.

 

Kann das jemand bestätigen? Weiß jemand, warum das so ist? Und vor allem: kann man dieses Verhalten verhindern? Es ist doch wenig sinnvoll, wenn das Handy die ganze Nacht nur über mobile Daten Mails usw. abruft.

 

Ich kann allerdings nicht mit 100%iger Sicherheit sagen, dass das WLAN tatsächlich ausgeht. Ich weiß nur, dass jedes Mal, wenn ich das Handy aktiviere, mein Virenscanner (Norton) das WLAN scannt (macht er nur bei neuen Verbindungen) und die "Connect App" von der Telekom sagt, dass ich mit keinem WLAN verbunden bin, sondern über mobile Daten im Internet bin.

 

Ich habe keine WLAN- oder Energiesparoptionen diesbezüglich gefunden.

61 ANTWORTEN 61
JunoK Moderator
Moderator

Hallo @King555,

 

nein, das sollte so eigentlich nicht sein. Mit den von dir genutzten Drittanbieter Apps kenne ich mich jedoch nicht aus und kann mir daher vorstellen, dass das Ganze eher mit diesen Anwendungen zusammenhängt und sich dein WLAN nicht wirklich ausschaltet... Solltest du näheres dazu herausfinden, halte mich gern auf dem Laufenden.

 


Liebe Grüße
JunoK
*Samsung Community Moderator*
*****************************
Endlich mehr Energie! Alles, was ihr zum Thema Akkuverbrauch wissen müsst, erfahrt ihr in unserem Artikel


 


 


 

Pathfinder

Es ist nur seltsam, dass beide Apps dieses Verhalten unter Android 8 nicht gezeigt haben. Daher dachte ich an irgendein neues Energiesparfeature von Android 9.

 

Ich werde mal die Entwickler beider Apps anschreiben, ob denen was bekannt ist.

Pathfinder

Mir fällt gerade noch was ein. Und zwar sehe ich jeden Morgen, dass WhatsApp mit dem Backup in die Google Cloud wartet, bis WLAN aktiviert ist. Das ist meiner Meinung nach ein noch wesentlich deutlicherer Hinweis darauf, dass WLAN tatsächlich aus ist.

Pathfinder

Kurzes Zwischenfeedback: Im Supportforum der Norton-App kann man sich keinen Reim darauf mache, warum die App ständig das WLAN scannt (seit Android 9). Man meinte, es liegt wohl eher am Handy bzw. Betriebssystem.

 

Ich habe mal folgenden Test gemacht: Auf der Statusseite meines Routers sehe ich, ob das Handy per WLAN verbunden ist. Ich habe das immer wieder kontrolliert, die Verbindung war immer da, auch wenn die beiden Apps das genannte Verhalten gezeigt haben. Schalte ich das WLAN aber manuell aus, zeigt die Statusseite das auch sofort an.

 

Somit scheint es zwar kein echtes Abschalten zu sein, aber irgendwas ist da doch anders seit Android 9. Man beachte auch das mit dem angehaltenen Whatsapp-Backup. Das klingt für mich nach irgendeiner Art von Energiesparmodus. Wobei der Energieverbrauch seit Android 9 so extrem hoch ist, dass das auch irgendwie seltsam wäre...

First Poster

hallo zusammen, das problem mit dem abschalten habe ich auch bemerkt! ich sehe es am besten, wenn das telefon neben meinem laptop liegt und ich whatsapp über den desktop nutze. die desktop anwendung fällt immer wieder 'offline', sodass meine geschriebenen nachrichten nicht gesendet werden, weil mein telefon anscheinend keine verbindung hat. also muss ich immer wieder mal das telefon entsperren und manchmal 'erwische' ich mein samsung auch dabei, wie es das wlan wieder einzuschalten scheint. danach funktioniert WA auf dem desktop wieder und die nachrichten gehen raus.

 

es stimmt, es ist nicht jedesmal der fall, einfach immer wieder mal. ich habe auch nicht herausgefunden, was die ursache sein könnte. die energiesparfunktion wlan im standbymodus eingeschaltet lassen ist bei mir auf 'immer'. @king555: hast du das auch? verbindungen - wlan - erweitert - mehr anzeigen - wlan im standbymodus eingeschaltet lassen
und bei mir verschwindets trotzdem manchmal...

 

gruss eulea

Superuser I
Superuser I
Versucht mal das:
Einstellungen》Gerätewartung》Akku》3 Pünktchen oben Rechts 》Adaptiver Akku aus.

Viele Grüße,
Eisik
*****************************
Hat dir mein Beitrag gefallen oder dein Problem gelöst ? Ich wäre froh über ein Like oder Markierung als Lösung des entsprechenden Beitrags.
Pathfinder

@Eulea 

Hast du auch Android 9? Weil bei mir gibt es diese Option nicht.

 

@Eisik 

Ist bereits seit einiger Zeit aus. Bringt aber nichts.

 

Übrigens hat sich die Mobildatennutzung seit Android 9 verdoppelt, was mit dem abgeschalteten WLAN zu tun haben könnte (kann auch Zufall sein).

 

Auch habe ich mich gefragt, ob der deutlich hörere Energiebedarf von Android 9 bei mir mit dem ständigen Ein- und Ausschalten zu tun hat. Unter Android 8 war das WLAN auf jeden Fall dauerhaft an und der Akku hielt ca. 15h mehr. Aber auch das kann Zufall sein.

First Poster

mein fehler, habe android 8, dafür die funktion von eisik nicht 😅

eigenartig ist allem voran, dass der 'bug' nicht regelmässig auftaucht. ich sehe auch keine regel...

Highlighted
Pathfinder
Die andere Funktion ist auf jeden Fall erst ab Android 9 verfügbar.

Ich hatte unter 8 nie das WLAN-Problem, erst ab 9.
Autoren, für die die meisten Likes vergeben wurden