Support

Open search

S7 Edge verliert im Standby Verbindung

Navigator

Leute, Samsung tut was sie können bzw. wollen, und seit Android Nougat können oder wollen sie dieses bekannte Problem nicht beheben. Findet Euch damit ab, jetzt wo immer mehr Konkurrenten im High-End-Bereich wegfallen wird sich daran auch nichts ändern.

 

Wäre ja auch zuviel verlangt, wenn Samsung bekannte Fehler, die in älteren Software-Versionen noch nicht auftraten (somit also garantiert kein Hardware-Problem sind) zeitnah oder überhaupt jemals fixen würde. Die Leute kaufen ja doch.

 

Zur Sache: das genannte Problem mit WLAN-Abbrüchen im Standby habe ich auch, besonders im 5GHz-Bereich. Habe ich auch schon vor einem Jahr gemeldet. Tut sich aber nichts.

 

Dabei ist das völlig einfach nachzuvollziehen: Unter Windows eine Kommandozeile geöffnet, und dort "ping -a <IP-Adresse S7>" eingeben. Solange das Display an ist, hat man Antwortzeiten von unter 100ms. Sobald es aus ist, kommt es zu sekundenlangen Verzögerungen und schließlich Fehlern. Gehte es wieder aus, siehe oben.

 

Eigentlich sollte ein Entwickler, der das Problem auch lösen will, das damit ganz gut eingrenzen können. Aber Bugfixing bringt keine Umsätze, also schminkt Euch das ab :(

First Poster

So.. Nach unzähligen Threads ohne konkreten Lösungsansatz seit 2016 hat mir meine Frau vor zwei Monaten ein S7 geschenkt.. Mein vorheriges S4 lief ohne Probleme im WLAN.. 

Das S7 leider schon.. ! 😤

 

Mittlerweile haben wir August 2018 und  ANDROID 8  !!  

.. und ...??

Leider immer noch schaltet sich das WLAN trotz  Einstellung "immer an" und ausgeschaltetem 5GHz an der neue. Fritzbox 7490..

Wat Nu..  ???

 

LG

Andre

JunoK Moderator
Moderator

Hallo @BulldogISL,

 

in einem anderen Thread hat mein Kollege mal ein ausführliches Troubleshooting für Fehler dieser Art zusammengefasst:

 

  • Schalte dein  Galaxy S7 einmal aus und wieder ein.
  • Schalte deinen Router einmal aus und wieder ein.
  • Gehe in "Einstellungen > Verbindungen > WLAN > Erweitert > WLAN im Standbymodus eingeschaltet lassen" und schalte auf "Nie" um. Starte das Gerät neu und setze jetzt die Einstellung wieder auf "Immer".
  • "Einstellungen > Verbindungen > WLAN" öffnen. Auf den Eintrag des verbunden WLANs tippen. Prüfen, ob der Haken bei "Automatisch erneut verbinden" gesetzt ist.
  • Lösche das WLAN einmal aus dem Samsung Galaxy S7, starte das Gerät neu und richte das WLAN wieder ein.
  • Stell in den WLAN-Optionen die IP von "DHCP" auf "statisch" um.
  • Überprüfe, ob es Updates für deinen Router gibt und installiere sie gegebenenfalls.
  • Starte dein  Galaxy S7 im "Sicheren Modus" und teste, ob die Verbindung hier stabiler ist. Falls ja: Liegen die Netzabbrüche an einer App. Finde heraus, welche App schuld ist und lösche sie.
  • Setz die Netzwerkeinstellungen deines Smartphones zurück: "Einstellungen > Allgemeine Veraltung > Zurücksetzen > Zurücksetzen von Einstellungen".
  • Setze die Einstellungen deines Smartphones zurück: "Einstellungen > Allgemeine Veraltung > Zurücksetzen > Einstellungen zurücksetzen".
  • Sichere deine persönlichen Daten und setze dein Smartphone auf die Werkseinstellungen zurück. Spiel anschließend nicht sofort das Backup wieder ein, sondern teste erst einmal, ob das Galaxy S7 "clean" stabil verbunden bleibt. Falls ja: spiel die Daten und Apps nach und nach wieder auf und beobachte das Verhalten.
  • Probiere einen anderen Router aus.

 

Gib dann bitte bescheid, ob dir diese Tipps geholfen haben. 

 


Liebe Grüße
JunoK
*Samsung Community Moderator*
*****************************
Dein Smartphone tut merkwürdige Dinge und nichts scheint zu helfen? Der Werksreset muss her. Hier erfährst du, wie du ihn ausführst.


 

Navigator

Alle diese Tips wurden von den meisten Leuten mit Problemen schon berücksichtigt, sofern realistisch.

 

Unrealistisch sind alle Vorschläge, die einen Werksreset des Telefons beinhalten, auch wenn die das Problem vielleicht lösen würden. Einen Totalverlust aller Einstellungen und möglicherweise Daten werde ich nicht akzeptieren. Ebenso unrealistisch sind alle Vorschläge, irgendwas am Router zu ändern, umzustellen oder upzudaten, denn es betrifft alle Router, und den in meiner Firma oder im Hotel kann ich nicht mal eben umkonfigurieren.

 

Es ist auch falsch zu behaupten, das Telefon sei irgendwie zufällig nach dem Update auf Nougat (denn erst seit diesem Update treten die Fehler auf, davor war alles wunderbar) kaputt gegangen. Es handelt sich eindeutig um ein Softwarproblem, denn einige User haben Marschmellow wieder eingespielt oder zumindest ein altes Modem aus einem Marschmellow-Image, und damit lief wieder alles. Leider scheidet so eine Frickellösung aber auch aus.

 

Ich habe allerdings rausgefunden bzw. im Internet in anderen Foren gelesen, daß es irgendwie mit Google's Doze zu tun hat. Der läßt sich über die ADB per USB abschalten, und wenn man das macht, bleibt das WLAN auch im Standby aktiv. Das ist eindeutig reproduzierbar, leider muß es aber nach jedem Reboot erneut gemacht werden.

 

Der Fehler liegt also daran, daß Google mit Doze über das Ziel hinausschießt und gleich auch WLAN mit in den Ruhezustand versetzt. Doze kann man aber meines Wissens nicht separat nur für WLAN ausschalten, sondern nur komplett, und leider nur bis zum nächsten Reboot. Das mache ich nun schon seit mehreren Wochen so, klappt einwandfrei.

 

Irgendwelche Nachteile bei der Akkulaufzeit habe ich nicht festgestellt, im Gegenteil: Weil WLAN jetzt aktiv bleibt, muß nicht auf mobile Daten zurückgegriffen werden, die wesentlich mehr Strom (und Datenvolumen) verbrauchen. Also eine Win-Win-Situation.

 

[von Moderator entfernt]

 

Samsung ist also eigentlich wirklich unschuldig an diesem Problem, es tritt anscheinend bei vielen anderen Marken ebenso auf. Google hat's verbockt. Vielleicht kan Samsung aber "beratend" tätig werden und Google zu einer nachhaltigen Lösung "überreden".

Navigator

Klasse, gibt es irgendeinen Grund warum meine Antwort von heute Mittag kommentarlos gelöscht worden ist? Die enthielt einen konkreten Lösungsvorschlag. Ist der nicht erwünscht?

JudithH Moderator
Moderator

Hallo skr, 

 


@skr  schrieb:

Klasse, gibt es irgendeinen Grund warum meine Antwort von heute Mittag kommentarlos gelöscht worden ist? Die enthielt einen konkreten Lösungsvorschlag. Ist der nicht erwünscht?


Dein Beitrag war am Wochenende automatisch im Spam hängen geblieben. Da habe ich ihn jetzt heute morgen herausgefischt. 

Allerdings habe ich ihn bei der Gelegenheit auch gleich editiert. Denn die Entwickleroptionen sind nicht für den dauerhaften Gebrauch von Nicht-Entwicklern gedacht. Dort etwas zu verändern, wenn man sich nicht richtig auskennt, kann böse enden. Deshalb habe ich die von dir gepostete Anleitung entfernt, damit hier niemand aus versehen sein Gerät kaputt macht oder sich die Einstellungen komplett zerschießt. 

 

Ich kann deine Erkenntnisse aber gerne mal weiterleiten. 

 

Viele Grüße

JudithH
*Samsung Community - Moderator*
----------------------------------------------
Breaking News: Neue Sterne am Galaxy-Himmel gesichtet!
Hier erfahrt ihr alles über die neue Galaxy S10 Serie! 

Navigator

Ernsthaft?

 

Naja, immerhin auch eine Antwort... Ich stimme zu daß das Herumspielen mit der ADB nicht jedermanns Sache ist und Doze von Google repariert gehört, damit der Workaround mit den Entwickleroptionen garnicht erst erforderlich ist. Daher danke für's Weiterleiten. Aber daß das Nutzen einer offiziellen Android-Funktion (aka Entwickleroptionen) offiziell verboten sein soll, ist mir neu. Einstellungen kann man generell falsch setzen und sich damit sein Gerät "zerschießen" -- nicht nur dort.

First Poster

Ja.. seit Langem scheint dieses Problem jetzt in zahlreichen Foren ohne Lösung behandelt zu werden..

Richtige Pipeline hier, aber Pipeline ohne Ziel...

Bin gerade an der Samsung Hotline an die Technik weitergeleitet worden.. Ganz plötzlich war die Leitung weg..

 

Problem offensichtlich zahlreich erkannt, aber keine Lösung !! 🤬🤬😡😡

Highlighted
First Poster

 

Der Fehler liegt also daran, daß Google mit Doze über das Ziel hinausschießt und gleich auch WLAN mit in den Ruhezustand versetzt. Doze kann man aber meines Wissens nicht separat nur für WLAN ausschalten, sondern nur komplett, und leider nur bis zum nächsten Reboot. Das mache ich nun schon seit mehreren Wochen so, klappt einwandfrei.

 

Irgendwelche Nachteile bei der Akkulaufzeit habe ich nicht festgestellt, im Gegenteil: Weil WLAN jetzt aktiv bleibt, muß nicht auf mobile Daten zurückgegriffen werden, die wesentlich mehr Strom (und Datenvolumen) verbrauchen. Also eine Win-Win-Situation.

 

Und so geht's (Voraussetzung: Android-SDK mit ADB):

 

1. Telefon in den Entwickleroptionen in den USB-Debugging-Modus schalten.

2. Per USB mit dem PC verbinden.

3. Eine DOS-Box (Eingabeaufforderung) im Administratormodus starten.

4. In den entsprechenden Installations-Pfad wechseln (z.B. cd "\<Installationspfad ADB>\platform-tools"

5. adb devices

6. adb shell dumpsys deviceidle disable

7. USB-Debugging wieder ausschalten.

 

Fertig.

Explorer

Auch unter Anroid 8.0 hat Google mittlerweile nachträglich Google eigene Standby Funktion intergriert. Diese findet man unter "Einstellungen - Apps - Name der betroffnen App - Akku". Hier muss stehen "App nicht optimiert", damit diese bei gesperrtem Gerät im Standby weiter laufen können.

Autoren, für die die meisten Likes vergeben wurden