Support

Open search

SD Card not mounting in S7 Edge due to "Security Policy"

SOLVED
First Poster

All of a sudden, my S7 Edge stopped recongising the SD Card (high quality legit one). I took it out, restarted the phone, and replaced it back in. Now I get a message when I try to Mount the SD card which says "Security Policy restricts the use of SD Card". But I have no idea how to get round this or what to change.

 

I select - Settings > Device Maintenance > Storage > 3-button-top-right-menu > Storage Settings >

 

This then shows the Internal Storage, and below shows "SD Card Unmounted" under external storage.

 

I click on this and select "Mount", which then gives me a message in a grey box saying: "Security Policy Restricts the use of SD Card"

 

The phone/card has not been dropped or exposed to water. There are no updates pending. And I have tried swapping my SD card to my partner's phone and vice versa, and both work the other way around. Help?????

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
KellyM Moderator
Moderator

Thanks, email isn't generally under this setting. Are you using a business e-mail account? Can you remove your e-mail account from the phone, restart it, then try to mount the SD card again?

 

Let us know how it goes! 

 

 

View solution in original post

KellyM Moderator
Moderator

Ah, that's great! Glad we got to the bottom of this! :smileyvery-happy:

 

There's a chance that you might be able to re-add the email account with the SD card already mounted. It may ask you to encrypt the SD card and its data. This would mean that you could access the files already on the card, but you wouldn't be able to add to them. This all of course depends on the security policies that are in place in relation to your Business email account. 

 

Happy we could help! 

View solution in original post

7 REPLIES 7
TracyR Moderator
Moderator

Hey @Martyn_R,

 

That's strange, we've forwarded it off to our techy people for further advice. 

 

As soon as they respond one of us Mods will get back to you. 

 

:womanhappy:

Sherlock 2.jpg
Say "hello!" and
 
Introduce Yourself, or virtually hangout in the Samsung Lounge

KellyM Moderator
Moderator

Hey @Martyn_R,

 

Can you provide a screenshot of what you can see under the following settings? Head to: Lock Screen and Security > Other Security Settings > Device Administrators.

 

We'd like to see if you have anything in here that might be restricting the SD card. 

First Poster

Screenshot_20170616-124453.png

 

Highlighted
KellyM Moderator
Moderator

Thanks, email isn't generally under this setting. Are you using a business e-mail account? Can you remove your e-mail account from the phone, restart it, then try to mount the SD card again?

 

Let us know how it goes! 

 

 

View solution in original post

First Poster

Kelly - you are an absolute star. That's sorted it. Thanks so much. As long as I know I need to remove my Business email when I want to access my music, that's easy. Fantastic work, thanks so much

KellyM Moderator
Moderator

Ah, that's great! Glad we got to the bottom of this! :smileyvery-happy:

 

There's a chance that you might be able to re-add the email account with the SD card already mounted. It may ask you to encrypt the SD card and its data. This would mean that you could access the files already on the card, but you wouldn't be able to add to them. This all of course depends on the security policies that are in place in relation to your Business email account. 

 

Happy we could help! 

View solution in original post

New Member

I followed these instructions, turned out my SD card wasn't visible as it showed up corrupted, reformatted it and bingo, works again. I was just about to give up (had tried it in a different phone and it wasn't showing up there either) and buy a new card so thanks for these instructions.

Top Liked Authors