Support

Open search

[Galaxy S6 Edge] Clear case not working after March 2018 update.

Highlighted
SOLVED
Apprentice

Pretty much as the title says. After yesterdays security update my clear case no longer shows anything (doesn't show the time, can't take calls, etc.) or unlocks my phone. The magnet is still where it should be. Any ideas how to fix this?

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice

I found a SOLUTION!

  • Go  to  Connections in Settings and enable the NFC and payment option  . 
  • Switch off your device
  • Remove the device from the flip cover
  • Turn the device back on
  • Put the device back in the flip cover
  • Switch NFC and payment off again
  • In the Advanced functions menu, the Accessories option is again at the top, automatic unlocking can be enabled

 

View solution in original post

6 REPLIES 6
First Poster

Hi,

 

I'm having the same issue after the April update. Just started to happen after the update took place.

Observer

I am having same issue with April update on Samsung S6. There must be fault in the software update... my life has now stalled! No solution in sight!

Apprentice

The same situation with my Samsung Galaxy S6 Edge. Clear case stopped working after april Nougat android update.

I tried to take the phone out and put it back to the case, but it didn't helped. There are no longer Accessory  option in Advanced features menu.

Who can help us??? 

Apprentice

I found a SOLUTION!

  • Go  to  Connections in Settings and enable the NFC and payment option  . 
  • Switch off your device
  • Remove the device from the flip cover
  • Turn the device back on
  • Put the device back in the flip cover
  • Switch NFC and payment off again
  • In the Advanced functions menu, the Accessories option is again at the top, automatic unlocking can be enabled

 

View solution in original post

First Poster

Hi,

 

The restart and NFC thing seems to do the trick...the only issue is that after a while the same issue comes back again, having to do the whole process again. 

 

I'm not sure what is triggering it as it happens sporadically (so it seems). Sometimes every few days, sometimes twice a day.

 

Thanks for all the help, hopefully someone can figure it out.

First Poster

Excellent.

Everything works again  

Thank You 

Top Liked Authors